Falha no erro de construção do Maven

10

Como abaixo, tive um erro ao executar mvn package

    [ERROR] Failed to execute goal org.apache.maven.plugins:maven-jar-plugin:2.3.1:jar (default-jar) on project hello-world: Execution default-jar of goal org.apache.maven.plugins:maven-jar-plugin:2.3.1:jar failed: Unable to load the mojo 'jar' in the plugin 'org.apache.maven.plugins:maven-jar-plugin:2.3.1'. A required class is missing: org/codehaus/plexus/components/io/resources/PlexusIoResourceCollection
    [ERROR] -----------------------------------------------------
    [ERROR] realm =    plugin>org.apache.maven.plugins:maven-jar-plugin:2.3.1
    [ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
    [ERROR] urls[0] = file:/C:/maven/repository/org/apache/maven/plugins/maven-jar-plugin/2.3.1/maven-jar-plugin-2.3.1.jar
    [ERROR] urls[1] = file:/C:/maven/repository/junit/junit/3.8.1/junit-3.8.1.jar
    [ERROR] urls[2] = file:/C:/maven/repository/org/apache/maven/maven-archiver/2.4.1/maven-archiver-2.4.1.jar
    [ERROR] urls[3] = file:/C:/maven/repository/org/codehaus/plexus/plexus-archiver/1.0/plexus-archiver-1.0.jar
    [ERROR] urls[4] = file:/C:/maven/repository/commons-lang/commons-lang/2.1/commons-lang-2.1.jar
    [ERROR] urls[5] = file:/C:/maven/repository/org/codehaus/plexus/plexus-utils/2.0.5/plexus-utils-2.0.5.jar
    [ERROR] Number of foreign imports: 1
    [ERROR] import: Entry[import  from realm ClassRealm[maven.api, parent: null]]
    [ERROR] 
    [ERROR] -----------------------------------------------------: org.codehaus.plexus.components.io.resources.PlexusIoResourceCollection
    [ERROR] -> [Help 1]
    [ERROR] 
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR] 
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginContainerException

Este é o meu pom.xml. Eu me livrei de coisas desnecessárias, mas ainda assim não funcionou ..

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">

<modelVersion>4.0.0</modelVersion>
<groupId>sds.jetty.simple</groupId>
<artifactId>hello-world</artifactId>
<version>1.0</version>
<packaging>jar</packaging>
<name>Jetty HelloWorld</name>

<properties>
    <jettyVersion>8.1.2.v20120308</jettyVersion>
</properties>

<dependencies>
    <dependency>
        <groupId>org.eclipse.jetty</groupId>
        <artifactId>jetty-server</artifactId>
        <version>${jettyVersion}</version>
    </dependency>
</dependencies>

<build>
</build>
</project>

por favor me ajude.

    
por verystrongjoe 11.09.2012 в 08:55
fonte

7 respostas

5

Tente remover para a pasta

.m2\repository\org\apache\maven\plugins\maven-jar-plugin

no seu sistema de arquivos. Seu plugin pode estar corrompido.

Se isso não funcionar, tente remover a pasta jetty-server (mesmo motivo)

    
por Samuel EUSTACHI 11.09.2012 / 17:38
fonte
1

Eu encontrei um problema semelhante uma vez. Acabou sendo um problema do maven 3. Depois de mudar para o maven 2.2.1 minha build correu bem.

    
por www.thuvien247.net 14.09.2012 / 10:16
fonte
1

Até mesmo enfrentamos esse problema. Ele será resolvido apenas excluindo a pasta .m2 / repository e construindo o Projeto novamente.

    
por nisarga 27.10.2017 / 16:20
fonte
0

está funcionando para mim para o seu arquivo POM de exemplo, o problema deve estar em outro lugar.

Tem certeza de que não há problemas de conexão? Seu software antivírus não impede o download de artefatos? Uma entrada no seu repositório local não está corrompida?

    
por rlegendi 11.09.2012 / 11:18
fonte
0

Para nós, isso foi causado quando o Eclipse / Maven alterou automaticamente nosso JDK para 1.5 (de 1.8). Mudar manualmente de volta para o 1.8 resolveu o problema.

    
por Ryan S 25.02.2015 / 22:11
fonte
0

Isso é um problema não resolvido no Maven 3.3.1 e 3.3.3; link Eu atualizei para o 3.3.9 e as coisas começaram a funcionar.

    
por Rudraksh Khandelwal 27.07.2016 / 06:48
fonte
0

Eu recentemente encontrei o problema e eu só preciso remover as pastas do .m2 / repository e re-executar o pom. funcionou.

    
por arn-arn 28.09.2016 / 21:49
fonte