Erro de NuGet “Pacotes externos não podem depender de pacotes que visam projetos” ao instalar o SNAP 1.4

9

Eu recebo o seguinte erro ao tentar instalar o SNAP 1.4 em um novo projeto VS2010 usando o Nuget 1.3:
"Pacotes externos não podem depender de pacotes que visam projetos"

Isso é um problema com o pacote SNAP Nuget, ou estou fazendo algo errado?

  

PM > SNAP de pacote de instalação   'Castle.Core (≥ 2.5.2)' não instalado. Tentando recuperar a dependência da origem ...   Feito.
  Install-Package: Pacotes externos não podem depender de pacotes que visam projetos.
  Na linha: 1 char: 16
  + Pacote de instalação < < < < SNAP
      + CategoryInfo: NotSpecified: (:) [Install-Package], InvalidOperationException
      + FullyQualifiedErrorId:
NuGetCmdletUnhandledException, NuGet.PowerShell.Commands.InstallPackageCommand

    
por Jonas 09.05.2011 в 11:46
fonte

2 respostas

3

Lendo este assunto aqui:

link

Parece que isso acontece se um projeto que não tem qualquer conteúdo depende de um que faz. Não tenho certeza se isso sempre falha, ou apenas quando não há um "projeto atual". Lembro-me de ver um menu suspenso "Projeto padrão" no Console do Gerenciador de Pacotes, portanto, não tenho certeza de por que isso não funcionaria.

Você pode tentar instalá-lo por meio da interface do usuário? (clique com o botão direito do mouse na pasta de referências do projeto, em seguida, clique em Add Library Package (ou similar)). Além disso, verifique se você tem um projeto selecionado no Gerenciador de Soluções e / ou no Pacote Padrão na janela do console.

    
por Danny Tuppeny 09.05.2011 / 14:13
fonte
0

Isso não é mais o caso. O pacote SNAP pode ser instalado com sucesso em um projeto. Meu ambiente é VS 2012 + NuGet 2.7.

    
por Fei Ling 29.10.2013 / 04:09
fonte