O iTunes Connect CFBundleShortVersionShort deve conter uma versão superior

9

Hoje, o Xcode está me dando problemas ao tentar enviar uma construção para o iTunes connect. Está me dando os seguintes erros:

O que é muito estranho é o CFBundleVersionShortVersionString do seu aplicativo 2.0.0 . Eu carreguei uma compilação para o TestFlight ontem e funcionou muito bem. Em seguida, fiz uma pesquisa por CFBundleVersionShortVersionString e encontrei um 1.0.0 e 0.5.1 , mas eles estavam no info.plist nos pods. Por que esse erro aparece de repente? Eu sei que não devo mudar nada nos Pods. Alguém já se deparou com este problema e, em caso afirmativo, como você pode consertar isso?

    
por Mike Walker 22.10.2015 в 01:06
fonte

1 resposta

2

Parece que houve um problema criado para esse mesmo problema no CocoaPods - link

blixt menciona ...

  

Acho que são os servidores do iTunes Connect e não o Xcode 7.0   nem Xcode 7.1. Esse problema parece ter começado por volta das 10h. isto   é definitivamente um bug, e nós consertamos isso batendo em nossas dependências   Info.plist CFBundleShortVersionString até a mesma versão do nosso   app e voila - o iTunes Connect aceitou o pacote.

Esta é uma correção irritante, mas parece que consertar a versão curta dos arquivos Info.plist individuais (que suas dependências podem ter) até a versão do seu aplicativo deve fazer com que você passe por este erro por enquanto. Esta definitivamente não é uma solução a longo prazo.

    
por joshdholtz 22.10.2015 / 06:46
fonte